Scoutnet vzw

We connect scouts!
Het is momenteel 07 Feb 2023 3:48

Alle tijden zijn UTC + 1 uur

Plaats een nieuw onderwerp Reageren op dit onderwerp  [ 1 bericht ] 
Auteur Bericht
BerichtGeplaatst: 14 Aug 2008 13:14 
Site Admin
Site Admin

Geregistreerd: 30 Sep 2002 23:00
Berichten: 1806
------------SA-2008-047 - DRUPAL CORE - MULTIPLE VULNERABILITIES------------

* Advisory ID: DRUPAL-SA-2008-047

* Project: Drupal core

* Version: 5.x, 6.x

* Date: 2008-July-13

* Security risk: Highly critical

* Exploitable from: Remote

* Vulnerability: Multiple vulnerabilities


Multiple vulnerabilities and weaknesses were discovered in Drupal.


A bug in the output filter employed by Drupal makes it possible for malicious users to insert script code into pages (cross site scripting [ ] or XSS).

A bug in the private filesystem trusts the MIME type sent by the browser, enabling malicious users with the ability to upload files to execute cross site scripting attacks.

These bugs affects both Drupal 5.x and 6.x.


The BlogAPI module does not validate the extension of uploaded files, enabling users with the "administer content with blog api" permission to upload harmful files.

This bug affects both Drupal 5.x and 6.x.


Drupal forms contain a token to protect against cross site request forgeries [ ] (CSRF). The token may not be validated properly for cached forms and forms containing AHAH elements.

This bug affects Drupal 6.x.

User access rules can be added or deleted upon accessing a properly formatted URL, making such modifications vulnerable to cross site request forgeries (CSRF). This may lead to unintended addition or deletion of an access rule when a sufficiently privileged user visits a page or site created by a malicious person.

This bug affects both Drupal 5.x and 6.x.


The Upload module in Drupal 6 contains privilege escalation vulnerabilities for users with the "upload files" permission. This can lead to users being able to edit nodes which they are normally not allowed to, delete any file to which the webserver has sufficient rights, and download attachments of nodes to which they have no access. Harmful files may also be uploaded via cross site request forgeries (CSRF).

These bugs affect Drupal 6.x.

------------VERSIONS AFFECTED------------

* Drupal 5.x before version 5.10

* Drupal 6.x before version 6.4


Install the latest version:

* If you are running Drupal 5.x then upgrade to Drupal 5.10 [ ].

* If you are running Drupal 6.x then upgrade to Drupal 6.4 [ ].

If you are unable to upgrade immediately, you can apply a patch to secure your installation until you are able to do a proper upgrade. The patches fix security vulnerabilities, but do not contain other fixes which were released in these versions.

* To patch Drupal 5.9 use SA-2008-047-5.9.patch [ ... -5.9.patch ].

* To patch Drupal 6.3 use SA-2008-047-6.3.patch [ ... -6.3.patch ].

Berichten weergeven van de afgelopen:  Sorteer op  
Plaats een nieuw onderwerp Reageren op dit onderwerp  [ 1 bericht ] 

Alle tijden zijn UTC + 1 uur

Wie is er online?

Gebruikers in dit forum: Geen geregistreerde gebruikers en 1 gast

U mag geen nieuwe onderwerpen plaatsen in dit forum
U mag geen reacties plaatsen op onderwerpen in dit forum
U mag uw berichten niet wijzigen in dit forum
U mag uw berichten niet verwijderen in dit forum
U mag geen bijlagen plaatsen in dit forum

Zoeken naar:
Ga naar:  
Powered by phpBB® Forum Software © phpBB Group
Vertaald door